2026-01 - Stripe Community Payments Not Loading Payment Methods

Modified on Mon, 20 Apr at 12:23 AM

Issue

Some parents were unable to:

  • Make payments online, or

  • Store a payment method via the Community Portal.

This occurred because some Community IDs were linked to multiple Stripe Customer Accounts.


Impact

  • Affected Community Payments using Stripe only

  • Introduced in version 71.07

  • Pay Now payments were not impacted

  • Payment options failed to display on the Community Portal, preventing:

    • Ad‑hoc payments

    • Assigning payment methods to payment plans


Cause

Multiple Stripe Customer Accounts were created for the same Community ID, causing payment methods to not populate correctly.


Resolution

A database‑only hotfix has been identified and applied that:

  • Prevents multiple Stripe Customer Accounts from being created

  • Reconciles existing duplicate Stripe Customer Accounts

✅ No application update required
✅ No manual intervention required


Outcome

Parents can now successfully:

  • Add and manage stored payment methods

  • Complete ad‑hoc payments

  • Assign payment methods to payment plans

Manual Fix (not required as we have rolled this out on affected clients)

SQL Script - https://static.synergetic.net.au/Hotfix/DML-TRIAG-3532-Remove-Dup-Stripe-CommunityIDs.sql

Hotfix Patcher - https://static.synergetic.net.au/Hotfix/V71_91_1_2314_HotFixv71TRIAG3532StripeDuplicateCustomer_DBP…

 

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