Depreciation Calculation Error - G/L Code Not Supplied or Attempt to Post to Non-Authorised Account

Modified on Tue, 10 Mar at 3:28 AM

TABLE OF CONTENTS

Error 

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Cause

This error can be caused by two different scenarios:

It is commonly caused by an Asset Definition without an applicable G/L code entered into the Asset Definitions Maintenance > General (Tab) under the following fields:

  • G/L Deprec'n
  • G/L Accrued Dep'n
  • G/L Profit/Loss

 It can also be caused by an asset that has been setup with a 'Private Rate' without the necessary G/L code entered into the Asset Definitions Maintenance > General (Tab) under the following field:

  • G/L Private Use

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If you can't find which asset has a private use rate after looking you can create a support ticket to assist with that. 

This can also be caused by permissions to the GL not being adequate. If you have a G/L listed in the asset definitions that you do not have permissions to, this error will also appear.

Resolution

Lack of G/L Codes

In the first scenario where no Private Use Rate is set, it is likely that one or more Asset Definitions will not contain the necessary G/L Codes. These will have to be added by going to Asset Definition in GL > Asset Definitions Maintenance > General (Tab) and changing the following G/L Codes:

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Once G/L Codes are set here, the error should no longer appear.

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The Above example will cause the error

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The above example will not cause the error

If there are a lot of asset definitions, you can use the following query to find any currently active/in-use Asset Definitions that do not have an associated G/L Code.

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